This repository has been archived on 2023-01-08. You can view files and clone it, but cannot push or open issues or pull requests.
ptrcports/libdrm-static/APKBUILD

42 lines
1.1 KiB
Plaintext

# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=libdrm-static
pkgver=2.4.109
pkgrel=0
pkgdesc="Userspace interface to kernel DRM services"
url="https://dri.freedesktop.org/"
arch="x86_64"
# Requires a computer with gfx, no X running, build user in 'video' group..
options="!check"
license="MIT"
depends="linux-headers"
makedepends="meson libpthread-stubs eudev-dev libpciaccess-dev xmlto"
checkdepends="cunit-dev bash"
source="https://gitlab.freedesktop.org/mesa/drm/-/archive/libdrm-$pkgver/drm-libdrm-$pkgver.tar.gz"
builddir="$srcdir/drm-libdrm-$pkgver"
build() {
abuild-meson \
-Dfreedreno=true \
-Dtegra=true \
-Domap=true \
-Dexynos=true \
-Dvc4=true \
-Detnaviv=true \
-Dudev=true \
-Ddefault_library=static \
. output
meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
meson test -v -C output
}
package() {
install -Dm644 "$builddir"/output/libdrm.a "$pkgdir"/usr/lib/libdrm.a
}
sha512sums="
77afc048f449de2c3d8588b7ef9136f69fc11b9130a7364872ad30807407aa180ded27d37961e94a738f8b5db9a9b19266c8f00d9a39b3f6b33ecad2ea44bc7b drm-libdrm-2.4.109.tar.gz
"