This repository has been archived on 2023-01-08. You can view files and clone it, but cannot push or open issues or pull requests.
ptrcports/kouhai/APKBUILD

36 lines
834 B
Plaintext

# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=kouhai
pkgver=0_alpha9
_commit=5ae1015ff395a9e0474193c65b18b20da8fa95eb
pkgrel=0
pkgdesc="Your everyday IRC student"
url="https://git.sr.ht/~taiite/senpai"
arch="all"
license="ISC"
makedepends="go scdoc"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ptrcnull/kouhai/archive/$_commit.tar.gz"
builddir="$srcdir/kouhai-$_commit"
prepare() {
default_prepare
sed -i "s/production/$pkgver/" window.go
}
build() {
make GOFLAGS="$GOFLAGS"
}
check() {
go test ./...
}
package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
sha512sums="
7eb702a805668db303b9ce7da48cd8c22a6658a339faadfb00e29b99a2ddf54c77ab6231e6b3328085dbdbe9fff44e217ed8e6ea716c25542466192df115799e kouhai-0_alpha9.tar.gz
"