This repository has been archived on 2023-01-08. You can view files and clone it, but cannot push or open issues or pull requests.
ptrcports/htop-full/APKBUILD

49 lines
967 B
Plaintext

# Maintainer: psykose <alice@ayaya.dev>
pkgname=htop-full
pkgver=3.2.1
pkgrel=0
pkgdesc="Interactive process viewer"
url="https://htop.dev/"
arch="all"
license="GPL-2.0-or-later"
makedepends="
autoconf
automake
hwloc-dev
libcap-dev
libnl3-dev
linux-headers
lm-sensors-dev
ncurses-dev
python3
"
subpackages="$pkgname-doc"
options="!check" # no upstream/available test-suite
source="$pkgname-$pkgver.tar.gz::https://github.com/htop-dev/htop/archive/$pkgver.tar.gz"
builddir="$srcdir/htop-$pkgver"
prepare() {
default_prepare
NOCONFIGURE=1 ./autogen.sh
}
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-delayacct
make
}
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="
d7b76e28ee870ac572ba1d9606dec6f9475346a00e599ca15838017c97683f1fc1be40417b9c1e76128cacc8a60ff9ba88c6b237be1835d309f98329b25644fc htop-full-3.2.1.tar.gz
"